Инструменты пользователя

Инструменты сайта


astpanel:designer:crm2kz

ИНТЕГРАЦИЯ ПАНЕЛИ ТЕЛЕФОНИИ

Обратно, к списку конфигураций...

  • Руководство составлено для 1С:CRM 2.0.11.5.
  • Требуется панель телефонии версии 1.4.26.7.

Инструкции для прочих версий CRM2...

Сделайте РЕЗЕРВНУЮ КОПИЮ информационной базы.

Настройка поддержки

Необходимо включить возможность изменения конфигурации.

Порядок действий следующий:

  1. Убедитесь, что все пользователи завершили свою работу с программой.
  2. Сделайте РЕЗЕРВНУЮ КОПИЮ информационной базы.
  3. Запустите программу в режиме «Конфигуратор».
  4. Откройте окно настройки поддержки «Конфигуратор» - «Поддержка» - «Настройка поддержки».
  5. Включите возможность изменения конфигурации. На предупреждение программы ответьте утвердительно.
  6. В появившемся окне укажите, что объекты поставщика редактируются с сохранением поддержки.

Конфигурация готова к внесению изменений.

Создание новых объектов

  1. Вставьте внешнюю обработку, которая идет в поставке, присвойте ей имя «МИКО_ПанельТелефонииДля1С».
  2. Добавьте новый общий модуль «МИКО_Софтфон».
  3. Установите флажки напротив свойств «Сервер» и «Вызов сервера» модуля.
  4. Скопируйте текст, расположенный по данной ссылке, и вставьте его в модуль «МИКО_Софтфон».

Настройка прав доступа

  1. Добавьте в конфигурацию новую роль «МИКО_Софтфон».
  2. Снимите все отметки о правах выставляемые по умолчанию, а для обработки МИКО_ПанельТелефонииДля1СМИКО_ПанельТелефонииДля1С») установите все права.
  3. Аналогично, для обработки «сфпСофтФонВнешняяПанель».
  4. Назначьте право на использование компанды «ОткрытьСофтФон»
  5. В конфигурации перейдите к обработке «сфпСофтФонВнешняяПанель»
  6. Для команды «ОткрытьСофтФон» измените синоним на «Панель телефонии»

Изменение общих модулей

  1. Передите к общему модулю «сфпСофтФонПроКлиент»,
  2. К процедуре «сфпПриНачалеРаботыСистемы». В начало необходимо вставить фрагмент кода:
    // PT1C / Панель телефонии Asterisk / Начало
    НазваниеПанелиТелефонии = "Панель телефонии Asterisk (МИКО)";
    МИКО_Софтфон.ВыполнитьПервичнуюУстановку(НазваниеПанелиТелефонии);
    Если МИКО_Софтфон.Использовать(НазваниеПанелиТелефонии) Тогда
     
    	Отказ = Ложь;
    	Попытка
    	// Версии 1.4.25.10+ обработка переименована в "МИКО_ПанельТелефонииДля1С"
    	сфпФормаТелефонВнешняяПанель = ПолучитьФорму("Обработка.МИКО_ПанельТелефонииДля1С.Форма.Форма");
    	сфпФормаТелефонВнешняяПанель.ИнициализироватьПанельТелефонии(Истина, Отказ);
    	Исключение
    		Отказ = Истина;
    	КонецПопытки;
     
    	Если Отказ Тогда
    		Сообщить("Не удалось запустить ""Панель телефонии Asterisk""");
    	Иначе
    		сфпОбработаноВнешнееСобытие = Истина;
    	КонецЕсли;
    	Возврат;
    КонецЕсли;
    // PT1C / Панель телефонии Asterisk / Конец
  3. К процедуре «сфпПереподключитьСофтФон». В начало необходимо вставить фрагмент кода:
    // PT1C / Панель телефонии Asterisk / Начало
    Если МИКО_Софтфон.Использовать("Панель телефонии Asterisk (МИКО)") Тогда
    	Если сфпФормаТелефонВнешняяПанель = Неопределено Тогда
    		Попытка
    			сфпФормаТелефонВнешняяПанель = ПолучитьФорму("Обработка.МИКО_ПанельТелефонииДля1С.Форма.Форма");
    			сфпФормаТелефонВнешняяПанель.ИнициализироватьПанельТелефонии(Истина, Ложь);
    		Исключение
    			Сообщить("Не удалось запустить ""Панель телефонии Asterisk (МИКО)""!");
    			Возврат;
    		КонецПопытки;
    	Иначе
    		// Переопределение обработки команды 
    		Если сфпФормаТелефонВнешняяПанель.Открыта() Тогда
    			сфпФормаТелефонВнешняяПанель.Активизировать(); 
    		Иначе
    			сфпФормаТелефонВнешняяПанель.Открыть();
    		КонецЕсли;
    	КонецЕсли; 
    	Возврат;
    КонецЕсли;
    // PT1C / Панель телефонии Asterisk / Конец
  4. К процедуре «сфпПроверитьДоступностьСофтФона». В начало необходимо вставить фрагмент кода:
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если МИКО_Софтфон.Использовать("Панель телефонии Asterisk (МИКО)") Тогда
    		Возврат Истина;
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец

Изменение общих форм

  1. Перейти к общей форме «CRM_СообщенияПодключения». В модуле формы, в начало процедуры «ПриОткрытии» необходимо добавить фрагмент кода:
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если МИКО_Софтфон.Использовать("Панель телефонии Asterisk (МИКО)") Тогда
    		Возврат;
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец
  2. Перейти к общей форме «ПечатьДокументов». В конец процедуры «ПриСозданииНаСервере» необходимо добавить фрагмент кода:
    	// PT1C / Панель телефонии Asterisk / Начало
    	МИКО_Софтфон.ДобавитьКнопкиФаксаНаФормуПечати(ЭтаФорма);
    	// PT1C / Панель телефонии Asterisk / Конец
  3. После процедуры «ПриСозданииНаСервере», добавить дополнительные процедуры - обработки:
    &НаКлиенте
    Процедура МИКО_ОтправитьКакФакс()
    	Если НЕ МИКО_Софтфон.Использовать("Панель телефонии Asterisk (МИКО)") 
    		 ИЛИ сфпФормаТелефонВнешняяПанель = Неопределено Тогда
    	 	Возврат;
    	КонецЕсли;
     
    	ТабличныеДокументы = Новый СписокЗначений;
    	Для Каждого НастройкаПечатнойФормы Из НастройкиПечатныхФорм Цикл
    		Если Элементы[НастройкаПечатнойФормы.ИмяРеквизита].Вывод = ИспользованиеВывода.Разрешить И НастройкаПечатнойФормы.Печатать Тогда
    			ТабличныеДокументы.Добавить(ЭтотОбъект[НастройкаПечатнойФормы.ИмяРеквизита], НастройкаПечатнойФормы.Представление);
    		КонецЕсли;
    	КонецЦикла;
     
    	Если ТабличныеДокументы.Количество()=0 Тогда
    		Возврат;
    	Иначе
    		ТабДок = ТабличныеДокументы[0].Значение;
    	КонецЕсли; 
    	// отсылаем факс
    	сфпФормаТелефонВнешняяПанель.ОтправитьФайлПоФаксу(,ТабДок);	
    КонецПроцедуры // МИКО_ОтправитьКакФакс()
     
    &НаКлиенте 
    Процедура МИКО_Позвонить()
    	Если НЕ МИКО_Софтфон.Использовать("Панель телефонии Asterisk (МИКО)") 
    		 ИЛИ сфпФормаТелефонВнешняяПанель = Неопределено Тогда
    	 	Возврат;
    	КонецЕсли; 
     
    	ПараметрыПечати = Неопределено;
    	Если Параметры.Свойство("ПараметрыПечати",ПараметрыПечати)
    		 И ТипЗнч(ПараметрыПечати) = Тип("Структура") Тогда
     
    		Если ПараметрыПечати.Свойство("ОбъектыПечати")
    			  И ТипЗнч(ПараметрыПечати.ОбъектыПечати) = Тип("Массив")
    			  И ПараметрыПечати.ОбъектыПечати.Количество()>0 Тогда
     
    			Участник = МИКО_Софтфон.ПолучитьСсылкуНаУчастникаИзДокумента(ПараметрыПечати.ОбъектыПечати[0]);
    			Если ТипЗнч(Участник) = Тип("Массив") 
    				 И Участник.Количество()>0 Тогда
    				сфпФормаТелефонВнешняяПанель.ПозвонитьВыбравТелефон(Участник);
    			ИначеЕсли Участник <> Неопределено Тогда
    				СписокУчастников = Новый Массив(1);
    				СписокУчастников[0] = Участник;
    				сфпФормаТелефонВнешняяПанель.ПозвонитьВыбравТелефон(СписокУчастников);
    			КонецЕсли;
    		КонецЕсли;
    	КонецЕсли; 
     
    КонецПроцедуры

Документ "CRM_Событие"

В форму документа с именем «ФормаДокумента», в начало процедуры «ОбработкаОповещения» добавить:

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
 
	// PT1C // +
	Если ИмяСобытия = "PT1C_ИсходящийВызовНеУдался" 
		 И Параметр <> Неопределено 
		 И Параметр.ОснованиеЗвонка = Объект.Ссылка Тогда
		врТекстСообщения = ""+Формат(ТекущаяДата(),"ДЛФ=DDT") + " : Пытались позвонить клиету на номер "+Параметр.НомерТелефона+" - не дозвонились.";
		Объект.Результат = Объект.Результат + ?(ЗначениеЗаполнено(Объект.Результат), Символы.ПС, "") + врТекстСообщения;
	ИначеЕсли ИмяСобытия =  "PT1C_ЗаписьСобытия"
			  И Параметр <> Неопределено 
		 	  И Параметр.Ссылка = Объект.Ссылка Тогда	
		Если Параметр.НеДозвонились = Истина Тогда
			врТекстСообщения = ""+Формат(ТекущаяДата(),"ДЛФ=DDT") + " : "
							   + "Звонок клиенту на номер "+Параметр.НомерТелефона+" - дозвонились, но требуется перезвонить"+Символы.ПС
							   + Параметр.Содержание+Символы.ПС;
		Иначе
			врТекстСообщения = ""+Формат(ТекущаяДата(),"ДЛФ=DDT") + " : "
							   + "Успешно дозвонились клиенту на номер "+Параметр.НомерТелефона+".  Создан документ """+Источник+""", см. структуру подчиненности"+Символы.ПС
							   + Параметр.Содержание+Символы.ПС;
		КонецЕсли; 	  
		Объект.Результат = Объект.Результат + ?(ЗначениеЗаполнено(Объект.Результат), Символы.ПС, "") + врТекстСообщения;
	КонецЕсли;
	// PT1C // -

Добавление картинок

В общие картинки добавить

  1. Картинку с именем «МИКО_ЗаписьРазговора»
  2. Картинку с именем «МИКО_Телефон»
  3. Картинку с именем «МИКО_ОтправитьФакс»

Обновите конфигурацию базы данных:

Обратно, к списку конфигураций...

Первый запуск

  1. Необходимо запустить 1С под учетной записью администратора 1С.
  2. Перейдите в раздел «Общие настройки»
  3. Для текущего пользователя следует перейти в «Пользователи» - «Персональные настройки».
  4. Включите опции:
  • «Использовать СофтФон»
  • «Панель телефонии Asterisk (МИКО)»
  • «Использовать внутреннюю панель СофтФон»

  1. Перейдите в раздел «Общие настройки»
  2. «Сервис» - «Настройки системы», необходимо включить использование СофтФон

Перейти к инструкции по настройке в режиме предприятия

Коментарии

astpanel/designer/crm2kz.txt · Последние изменения: 2016/05/17 11:48 — icvet