Инструменты пользователя

Инструменты сайта


astpanel:fastintegration:ara10

Различия

Здесь показаны различия между двумя версиями данной страницы.

Ссылка на это сравнение

Предыдущая версия справа и слева Предыдущая версия
astpanel:fastintegration:ara10 [2018/08/17 08:32]
tpor
astpanel:fastintegration:ara10 [2018/08/17 08:33] (текущий)
tpor
Строка 191: Строка 191:
 {{ :​doc:​panel1cut:​dokument_sobytie.jpg?​ |}} {{ :​doc:​panel1cut:​dokument_sobytie.jpg?​ |}}
  
-==== 5. Данные незарегистрированных контрагентов ====+==== 5. Модернизация справочника "​Контрагенты"​ ==== 
 + 
 +=== Звонок из карточки Контрагента === 
 +**Задача:​** необходимо,​ добавить возможность произвести звонок из карточки контрагента.  
 + 
 +**Решение:​** необходимо модифицировать форму элемента справочника "​Контрагенты":​ 
 +<code 1c> 
 +// Обработчик события ПриОткрытии формы. 
 +// 
 +Процедура ПриОткрытии() 
 + 
 + // ... ... ... Внимание!!! Отсутствует часть исходного кода!!! 
 +  
 + // Установить печатную форму по умолчанию. 
 + РаботаСДиалогами.УстановитьКнопкуПечати(ЭтотОбъект,​ ЭтаФорма);​ 
 + // {{doc:​panel1cut:​{ МИКО Панель телефонии Asterisk }}} НАЧАЛО 
 + Если НЕ Miko_Ajam = Неопределено  
 + И НЕ Miko_Ajam.мОбщийМодуль = Неопределено Тогда 
 + мОбщийМодуль = Miko_Ajam.мОбщийМодуль;​ 
 + // добавляем элементы управления на форму 
 +  
 + мОбщийМодуль.ДобавитьКнопкуЗвонкаНаПанельДействий(ЭлементыФормы.ДействияФормы.Кнопки,​ 
 +                                                          "​МИКО_ВыполнитьДействие",​  
 +                                                          "​кнМИКО_НабратьНомерВыбравИзСписка"​);​ 
 + мОбщийМодуль.ДобавитьКнопкуЗвонкаНаПанельДействий(ЭлементыФормы.КоманднаяПанельКонтактнаяИнформация.Кнопки,​ 
 +                                                          "​МИКО_ВыполнитьДействие",​ 
 +                                                          "​кнМИКО_НабратьНомерИзКИ"​);​ 
 + мОбщийМодуль.ДобавитьКнопкуЗвонкаНаПанельДействий(ЭлементыФормы.КоманднаяПанельКонтактныеЛицаКонтрагента.Кнопки,​ 
 +                                                          "​МИКО_ВыполнитьДействие",​  
 +                                                          "​кнМИКО_НабратьНомерВыбравКЛ"​);​ 
 + КонецЕсли;​  
 + // {{doc:​panel1cut:​{ МИКО Панель телефонии Asterisk }}} КОНЕЦ  
 +КонецПроцедуры 
 +</​code>​ 
 + 
 +добавить обработчик нажатия кнопок:​ 
 + 
 +<code 1c> 
 +// МИКО // Набор номера по заданному алгоритму 
 +// Параметры  
 +//   ​Кнопка - элемент управления формы с типом "​КнопкаКоманднойПанели"​ 
 +Процедура МИКО_ВыполнитьДействие(Кнопка) 
 + ​ Действие = Кнопка.Имя;​ 
 + Если Miko_Ajam = Неопределено Тогда Возврат;​ КонецЕсли;​ 
 +  
 + Если Действие = "​кнМИКО_НабратьНомерИзКИ"​ Тогда 
 + // Позвонить по выбранному контакту  
 + ТекущаяСтрока = ЭлементыФормы.КонтактнаяИнформация.ТекущиеДанные;​ 
 + Если НЕ ТекущаяСтрока = Неопределено Тогда 
 + Miko_Ajam.НабратьНомерКИ(ЭлементыФормы.КонтактнаяИнформация.ТекущиеДанные);​ 
 + КонецЕсли;​  
 + ИначеЕсли Действие = "​кнМИКО_НабратьНомерВыбравИзСписка" ​ ТОгда 
 + // Позвонить по телефону,​ выбранному пользователем из списка телефонов определенных у контрагента и контактного лица 
 + СписокОбъектов = Новый Структура();​ 
 + СписокОбъектов.Вставить("​Контрагент",​ Ссылка);​ 
 + СписокОбъектов.Вставить("​КонтактноеЛицо",​ ОсновноеКонтактноеЛицо);​ 
 + Если НЕ Ссылка = ГоловнойКонтрагент Тогда 
 + СписокОбъектов.Вставить("​КонтактноеЛицо",​ ГоловнойКонтрагент);​ 
 + КонецЕсли;​  
 +  
 + Miko_Ajam.ПозвонитьВыбравТелефон(СписокОбъектов);​ 
 + ИначеЕсли Действие = "​кнМИКО_НабратьНомерВыбравКЛ"​ Тогда  
 + // Позовонить выбранному контактному лицу 
 + ТекущиеДанные = ЭлементыФормы.КонтактныеЛицаКонтрагента.ТекущиеДанные;​ 
 + Если НЕ ТекущиеДанные = Неопределено Тогда 
 + СписокОбъектов = Новый Структура();​ 
 + СписокОбъектов.Вставить("​КонтактноеЛицо",​ ТекущиеДанные.Ссылка);​ 
 + Miko_Ajam.ПозвонитьВыбравТелефон(СписокОбъектов);​ 
 + КонецЕсли;​ 
 + ИначеЕсли Действие = "​УстановитьДоступностьКнопокСофтфона"​ Тогда  
 + Miko_Ajam.мОбщийМодуль.УстановитьДоступностьКнопокСофтфона(ЭлементыФормы.КонтактнаяИнформация.ТекущиеДанные,​ 
 +                                                                              ЭлементыФормы.КоманднаяПанельКонтактнаяИнформация.Кнопки,​ 
 +  ​             "​кнМИКО_НабратьНомерИзКИ"​);​ 
 + КонецЕсли;​  
 +  
 +КонецПроцедуры 
 + 
 +</​code>​ 
 + 
 +Кнопки должны быть доступны только для контактной информации с типом "​Телефон"​ 
 +<code 1c> 
 +// Обработчик события ПриАктивизацииСтроки элемента формы КонтактнаяИнформация. 
 +// 
 +Процедура КонтактнаяИнформацияПриАктивизацииСтроки(Элемент) 
 +  
 + УправлениеКонтактнойИнформацией.КонтактнаяИнформацияПриАктивизацииСтрокиТаблицы(Элемент,​ ЭлементыФормы.КоманднаяПанельКонтактнаяИнформация.Кнопки.УстановитьОсновным);​ 
 + // {{doc:​panel1cut:​{ МИКО Панель телефонии Asterisk }}} НАЧАЛО 
 + Если НЕ Miko_Ajam = Неопределено 
 + И  НЕ Miko_Ajam.мОбщийМодуль = Неопределено Тогда 
 + МИКО_ВыполнитьДействие(Новый Структура("​Имя","​УстановитьДоступностьКнопокСофтфона"​));​ 
 + КонецЕсли;​ 
 + // {{doc:​panel1cut:​{ МИКО Панель телефонии Asterisk }}} КОНЕЦ  
 +КонецПроцедуры 
 +</​code>​ 
 + 
 +Форма элемента справочника примет следующий вид: 
 +{{ :​doc:​panel1cut:​forma_kontragenta.png?​ |}} 
 + 
 +==== 6. Данные незарегистрированных контрагентов ====
  
 В некоторых случаях удобно не регистрировать нового клиента,​ а сохранить его просто в документе "​Событие"​. \\ В некоторых случаях удобно не регистрировать нового клиента,​ а сохранить его просто в документе "​Событие"​. \\
Строка 204: Строка 302:
 Функцию заполнения ресурса воздет на себя панель телефонии (**поддерживается в версии 1.2.24.7+**). ​ Функцию заполнения ресурса воздет на себя панель телефонии (**поддерживается в версии 1.2.24.7+**). ​
  
-==== 6. Модернизация общей формы печати документов ====+==== 7. Модернизация общей формы печати документов ====
  
 === Отправка факсом текущего документа === === Отправка факсом текущего документа ===
astpanel/fastintegration/ara10.1534494754.txt.gz · Последние изменения: 2018/08/17 08:32 — tpor