Инструменты пользователя

Инструменты сайта


astpanel:fastintegration:crm2_0_12_1_6_10

Интеграция панели телефонии и журнала звонков в 1С:УНФ, ред. 1.6 + CRM, ред. 2.0

Обратно к перечню инструкций

Данная инструкция позволяет упростить и ускорить процесс внедрения панели телефонии и журнала звонков в концигурацию 1С на управляемом приложении.

Инструкции составлены для конфигураций:

  • 1С:Управление нашей фирмой, редакция 1.6 + CRM, редакция 2.0 (1.6.10/2.0.12) (1.6.10.56)

Рекомендуемая версия панели телефонии: 1.4.26.20+
Рекомендуемая версия журнала звонков: 1.0.1.15+

Этап 1. Настройка правил поддержки

Перед началом выполнения работ обязательно сделайте резервное копирование конфигурации и данных!

Для начала следует разблокировать головной объект конфигурации для внесения изменений.

Порядок действий следующий:

  1. Убедитесь, что пользователи завершили работу с программой.
  2. Запустите программу в режиме «Конфигуратор».
  3. Откройте окно настройки поддержки.
  4. Включите возможность изменения конфигурации. На предупреждение программы ответьте утвердительно.
  5. В появившемся окне укажите, что объекты поставщика не редактируются.
  6. Затем для головного объекта конфигурации («УправлениеНебольшойФирмой_CRM») установите правило поддержки на «Объект поставщика редактируется с сохранением поддержки».
  7. Для общего модуля «ВариантыОтчетовПереопределяемый» также установите правило поддержки на «Объект поставщика редактируется с сохранением поддержки».
  8. Для общего модуля «сфпСофтФонПроКлиент» также установите правило поддержки на «Объект поставщика редактируется с сохранением поддержки».
  9. Для общей формы «CRM_СообщенияПодключения» также установите правило поддержки на «Объект поставщика редактируется с сохранением поддержки».
  10. Закройте окно настройки поддержки

Теперь конфигурация готова к внесению изменений.

Этап 2. Встраивание журнала звонков

  1. Выполните действия «Конфигурация» - «Сравнить и объеденить с конфигурацией из файла»
  2. Выберите файл конфигурации «Module_Statistic_Х_Х_Х_ХХ.protect.cf»;
  3. Снимите флажок со всех объектов конфигурации
  4. Меню «Действия» - «Отметить по подсистемам файла»
  5. Выберите только те подсистемы, которые указаны на скриншоте, выполните действие «Установить»
  6. Выполните действие «Выполнить»
  7. В появившемся окне нажимаем «Продолжить». Сохраняем отчет сравнения/объединения нашей конфигурации с файлом.
  8. Сравнение и объединение будет завершено.

Изменение типовых объектов

Для завершения этапа встраивания журнала звонков необходимо внести изменения в общий модуль «ВариантыОтчетовПереопределяемый».

  1. Открываем общий модуль «ВариантыОтчетовПереопределяемый» для редактирования
  2. Переходим в процедуру «ОпределитьРазделыСВариантамиОтчетов»
  3. В конец процедуры добавляем строку кода:
    // МИКО / PT1C / Подсистема "Расширенный журнал звонков" / Начало
    	Разделы.Добавить(Метаданные.Подсистемы.МИКО_Телефония);
    	// МИКО / PT1C / Подсистема "Расширенный журнал звонков" / Конец

Этап 3. Встраивание панели телефонии

1. Добавление обработки в подсистему МИКО_Телефония

Замените обработку МИКО_ПанельТелефонииДля1С на внешнюю, которая идет в поставке, она должна называться МИКО_ПанельТелефонииДля1С.

2. Правка модуля управляемого приложения

  1. Откройте модуль управляемого приложения.
  2. Перейдите к процедуре «ПриЗавершенииРаботыСистемы» (создайте процедуру, если ее нет). В конец процедуры вставьте код приведенный ниже.
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если сфпПанельУправления <> Неопределено
    		 И ТипЗнч(сфпПанельУправления) = Тип("УправляемаяФорма") 
    		 И Найти(сфпПанельУправления.ИмяФормы,"Обработка.МИКО_ПанельТелефонииДля1С")<>0 Тогда
    		сфпПанельУправления.ЗавершитьРаботу(Истина);
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец

3. Изменение общих модулей

  1. Передите к общему модулю «сфпСофтФонПроКлиент»,
  2. К процедуре «сфпПодключитьСофтФон». В начало необходимо вставить фрагмент кода:
    	// PT1C / Панель телефонии Asterisk / Начало
    	НазваниеПанелиТелефонии = "Панель телефонии Asterisk (МИКО)";
    	Если сфпПанельУправления = Неопределено Тогда
    		МИКО_Софтфон.ВыполнитьПервичнуюУстановку(НазваниеПанелиТелефонии);
    	КонецЕсли; 
     
    	Если МИКО_Софтфон.Использовать(НазваниеПанелиТелефонии) Тогда
    		Если сфпПанельУправления = Неопределено Тогда
    			Попытка
    				сфпПанельУправления = ПолучитьФорму("Обработка.МИКО_ПанельТелефонииДля1С.Форма.Форма");
    				сфпПанельУправления.ИнициализироватьПанельТелефонии(Истина, Ложь);
    			Исключение
    				Сообщить("Не удалось запустить ""Панель телефонии Asterisk (МИКО)""!");
    				Возврат;
    			КонецПопытки;
    		Иначе
    			// Переопределение обработки команды 
    			Если сфпПанельУправления.Открыта() Тогда
    				сфпПанельУправления.Активизировать(); 
    			Иначе
    				сфпПанельУправления.Открыть();
    			КонецЕсли;
    		КонецЕсли; 
    		Возврат;
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец
  3. К процедуре «сфпПозвонить». В начало необходимо вставить фрагмент кода:
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если МИКО_Софтфон.Использовать("Панель телефонии Asterisk (МИКО)") Тогда
    		ОснованиеЗвонка = Неопределено;
     
    		Если ДанныеЗаполнения <> Неопределено
    			И ДанныеЗаполнения.Свойство("Основание") Тогда
     
    			ОснованиеЗвонка = Новый Структура("ОснованиеЗвонка, НомерТелефона", ДанныеЗаполнения.Основание, Телефон);
     
    		КонецЕсли;
    		сфпПанельУправления.Позвонить(Телефон,ОснованиеЗвонка);
    		Возврат;	
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец
  4. К процедуре «сфпПозвонитьВыбравТелефон». В начало необходимо вставить фрагмент кода:
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если МИКО_Софтфон.Использовать("Панель телефонии Asterisk (МИКО)") Тогда
    		сфпПанельУправления.ПозвонитьВыбравТелефон(СписокОбъектов);
    		Возврат;	
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец
  5. К процедуре «сфпПроверитьДоступностьСофтФон». В начало необходимо вставить фрагмент кода:
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если МИКО_Софтфон.Использовать("Панель телефонии Asterisk (МИКО)") Тогда
    		Возврат Истина;
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец

4. Изменение общих форм

  1. Перейти к общей форме «CRM_СообщенияПодключения». В модуле формы, в процедуре «ПриСозданииНаСервере» необходимо добавить фрагмент кода:
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
     
    	Если НЕ Параметры.Свойство("ВидФормы") Тогда
    		Отказ = Истина;
     
    	ИначеЕсли Параметры.ВидФормы = "СофтФон" Тогда
    		// PT1C / Панель телефонии Asterisk / Начало
    		Если МИКО_Софтфон.Использовать("Панель телефонии Asterisk (МИКО)") Тогда
    			Возврат;
    		КонецЕсли;
    		// PT1C / Панель телефонии Asterisk / Конец
     
    	// *** *** ***
    	// ВНИМАНИЕ ПРОПУЩЕНА ЧАСТЬ ИСХОДНОГО КОДА
    	// *** *** ***
     
    	КонецЕсли;
    КонецПроцедуры // ПриСозданииНаСервере()
  2. Перейти к общей форме «ПечатьДокументов». В конец процедуры «ПриСозданииНаСервере» необходимо добавить фрагмент кода:
    	// PT1C / Панель телефонии Asterisk / Начало
    	МИКО_Софтфон.ДобавитьКнопкиФаксаНаФормуПечати(ЭтаФорма);
    	// PT1C / Панель телефонии Asterisk / Конец
  3. После процедуры «ПриСозданииНаСервере», добавить дополнительные процедуры - обработки:
    &НаКлиенте
    Процедура МИКО_ОтправитьКакФакс()
    	Если НЕ МИКО_Софтфон.Использовать("Панель телефонии Asterisk (МИКО)") 
    		 ИЛИ сфпПанельУправления = Неопределено Тогда
    	 	Возврат;
    	КонецЕсли;
     
    	ТабличныеДокументы = Новый СписокЗначений;
    	Для Каждого НастройкаПечатнойФормы Из НастройкиПечатныхФорм Цикл
    		Если Элементы[НастройкаПечатнойФормы.ИмяРеквизита].Вывод = ИспользованиеВывода.Разрешить И НастройкаПечатнойФормы.Печатать Тогда
    			ТабличныеДокументы.Добавить(ЭтотОбъект[НастройкаПечатнойФормы.ИмяРеквизита], НастройкаПечатнойФормы.Представление);
    		КонецЕсли;
    	КонецЦикла;
     
    	Если ТабличныеДокументы.Количество()=0 Тогда
    		Возврат;
    	Иначе
    		ТабДок = ТабличныеДокументы[0].Значение;
    	КонецЕсли; 
    	// отсылаем факс
    	сфпПанельУправления.ОтправитьФайлПоФаксу(,ТабДок);	
    КонецПроцедуры // МИКО_ОтправитьКакФакс()
     
    &НаКлиенте 
    Процедура МИКО_Позвонить()
    	Если НЕ МИКО_Софтфон.Использовать("Панель телефонии Asterisk (МИКО)") 
    		 ИЛИ сфпПанельУправления = Неопределено Тогда
    	 	Возврат;
    	КонецЕсли; 
     
    	ПараметрыПечати = Неопределено;
     
    	Если ТипЗнч(ОбъектыПечати) = Тип("СписокЗначений")
    		И ОбъектыПечати.Количество() > 0 Тогда
     
    		Участник = МИКО_Софтфон.ПолучитьСсылкуНаУчастникаИзДокумента(ОбъектыПечати[0].Значение);
    		Если ТипЗнч(Участник) = Тип("Массив") 
    			И Участник.Количество()>0 Тогда
    			сфпПанельУправления.ПозвонитьВыбравТелефон(Участник);
    		ИначеЕсли Участник <> Неопределено Тогда
    			СписокУчастников = Новый Массив(1);
    			СписокУчастников[0] = Участник;
    			сфпПанельУправления.ПозвонитьВыбравТелефон(СписокУчастников);
    		КонецЕсли;
    	КонецЕсли; 
     
    КонецПроцедуры

Этап 4. Завершение этапа встраивания

Сохранение изменений

  1. Обновите конфигурацию базы данных.
  2. В отобразившемся окне нажмите Принять

Обновление конфигурации

  1. Запустите процесс обновления конфигурации. В конфигураторе перейдите в меню «Сервис» - «Параметры», вкладка «Запуск 1С:Предприятие»
  2. В поле «Параметры запуска» укажите строку «ЗапуститьОбновлениеИнформационнойБазы»
  3. Запустите 1С:Предприятие из конфигуратора «Отладка» - «Начать отладку»
  4. Дождитесь завершения обновления
  5. Удалите из параметров запуска строку «ЗапуститьОбновлениеИнформационнойБазы». Перезапустите 1С.

Завершение настройки

Операции требовательны к ресурсам ПК. Лучше их выполнить в нерабочее время.

  1. Запустите 1С Предприятие под полными правами в пользовательском режиме
  2. «Все функции» - «Обработки» - «МИКО: Заполнить индекс телефонов»
  3. Выполните действие «Заполнить коды городов»
  4. Выполните действие «Перезаполнить индекс номеров»

На этом встраивание панели телефонии и журнала звонков в конфигурацию завершено. Теперь можно перейти к настройке продуктов в режиме 1С:Предприятие:

Первый запуск

  1. Необходимо запустить 1С под учетной записью администратора 1С.
  2. Перейдите в раздел «Компания»
  3. Перейдите по ссылке «Администрирование» - «CRM: Настройки» - «CRM: Работа с СофтФон» необходимо включить использование Софтфон


  4. Перейдите в раздел «Компания» -«Сервис»-«Персональные настройки(CRM)».
  5. Включите опции:
  • «Использовать СофтФон»
  • «Панель телефонии Asterisk (МИКО)»
  • «Использовать внутреннюю панель СофтФон«

Запись вебинара

Запись вебинара по встраиванию панели телефонии и журнала звонков на примере конфигурации «Управление нашей фирмой, редакция 1.6».

Обратно к перечню инструкций

astpanel/fastintegration/crm2_0_12_1_6_10.txt · Последние изменения: 2018/05/04 07:46 — tpor