Инструменты пользователя

Инструменты сайта


astpanel:statistic:panelotchetov

Ошибка при открытии отчетов в журнале звонков

Обратно к инструкциям

Иногда возникает ситуация, когда при попытки открытия отчетов (Отчеты по звонкам в подсистеме МИКО_Телефония) возникает следующая ошибка:


Порядок действий подходит для версии журнала звонков 1.0.1.20+. Если у Вас используется более ранняя версия, то рекомендуем Вам сперва обновить модуль журнала звонков до актуальной версии.

Решение данной проблемы:

1. Вначале необходимо проверить структуру подсистемы телефонии.

На рисунке видно, что главной является подсистема МИКО_Телефония. Возможны случаи, когда наименование главной подсистемы телефонии принимает значение МИКО_ПанельТелефонии. Скопируйте наименование Вашей главной подсистемы телефонии, в нашем случае это МИКО_Телефония.

2. Переходим в общий модуль «ВариантыОтчетовПереопределяемый». Необходимо в процедуре «ОпределитьРазделыСВариантамиОтчетов» добавить раздел для подсистемы телефонии МИКО. Вставляем наименование нашей подсистемы телефонии МИКО_Телефония.

// Определяет разделы глобального командного интерфейса, в которых предусмотрены панели отчетов.
Процедура ОпределитьРазделыСВариантамиОтчетов(Разделы) Экспорт
 
	Разделы.Добавить(Метаданные.Подсистемы.МаркетингИПродажи, НСтр("ru = 'Маркетинг и продажи'"));
	Разделы.Добавить(Метаданные.Подсистемы.ЗапасыИЗакупки, НСтр("ru = 'Запасы и закупки'"));
	Разделы.Добавить(Метаданные.Подсистемы.Работы, НСтр("ru = 'Работы'"));
	Разделы.Добавить(Метаданные.Подсистемы.КомплектацияИПроизводство, НСтр("ru = 'Производство'"));
	Разделы.Добавить(Метаданные.Подсистемы.ДенежныеСредства, НСтр("ru = 'Деньги'"));
	Разделы.Добавить(Метаданные.Подсистемы.ЗарплатаИПерсонал, НСтр("ru = 'Зарплата и персонал'"));
	Разделы.Добавить(Метаданные.Подсистемы.Компания, НСтр("ru = 'Компания'"));
	// МИКО / PT1C / Подсистема "Расширенный журнал звонков" / Начало
	Разделы.Добавить(Метаданные.Подсистемы.МИКО_Телефония);
	// МИКО / PT1C / Подсистема "Расширенный журнал звонков" / Конец
 
КонецПроцедуры


3. Переходим в модуль команды МИКО_стПанельОтчетовИсторияЗвонков в процедуру ОбработкаКоманды. Проверяем правильность указанного наименования подсистемы телефонии, в нашем случае это МИКО_Телефония.

Ошибка «{ОбщаяКоманда.МИКО_стПанельОтчетовИсторияЗвонков.МодульКоманды(12)}: Слишком много фактических параметров» означает, что в процедуру ПоказатьПанельОтчетов передается слишком много параметров, необходимо удалить лишний.

В результате должно получиться следующим образом:

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
	
	Если ЕстьМодульБСП() Тогда
		Попытка
			ОбщийМодуль_ВариантыОтчетовКлиент = Вычислить("ВариантыОтчетовКлиент");
			Если ОбщийМодуль_ВариантыОтчетовКлиент <> Неопределено Тогда
				// МИКО / PT1C / Убираем один параметр процедуры
				ОбщийМодуль_ВариантыОтчетовКлиент.ПоказатьПанельОтчетов("МИКО_Телефония", ПараметрыВыполненияКоманды);
			КонецЕсли;
		Исключение
			ЗаписатьОшибкуВЖурналРегистрации(""+ОписаниеОшибки());
		КонецПопытки; 
	Иначе	
		ОткрытьФорму("Отчет.МИКО_стПанельОтчетов.Форма.ФормаОтчета");
	КонецЕсли; 
	
КонецПроцедуры

4. Выполните обновление информационной базы. Данный этап «Обновление конфигурации» описан здесь.

astpanel/statistic/panelotchetov.txt · Последние изменения: 2018/08/14 08:22 — tpor