Инструменты пользователя

Инструменты сайта


astpanel:designer:crm2:crm2071

ИНТЕГРАЦИЯ ПАНЕЛИ ТЕЛЕФОНИИ

Руководство составлено для 1С:CRM 2.0.7.1 И УТ+CRM редакции 2.0.6.2 и панели телефонии Asterisk 1.x.21 и может быть не актуальным для других версий.

Сделайте РЕЗЕРВНУЮ КОПИЮ информационной базы.

Предварительная настройка

Выполните предварительную настройку в режиме 1С:Предприятие согласно данной инструкции.

Этап 1. В режиме "Конфигуратор"

Для начала следует разблокировать корневой объект конфигурации для внесения изменений.

Порядок действий следующий:

  1. Сперва убедитесь, что все пользователи завершили свою работу с программой. После чего запустите программу в режиме «Конфигуратор».
  2. Откройте окно настройки поддержки.
  3. Включите возможность изменения конфигурации. На предупреждение программы ответьте утвердительно.
  4. В появившемся окне укажите, что объекты поставщика не редактируются.
  5. Затем для корневого объекта конфигурации установите правило поддержки «Объект поставщика редактируется с сохранением поддержки».

Теперь конфигурация готова к внесению изменений.

2013/08/06 13:54 · nb
  1. Включить возможность изменения для команды ОткрытьСофтфон из обработки сфпСофтФонВнешняяПанель.

Необходимо встроить внешнюю обработку (панель телефонии) в конфигурации, настроить права доступа и ее автоматический запуск в фоновом режиме.

Создание новых объектов

  1. Вставьте внешнюю обработку, которая идет в поставке, в конфигурацию и назовите ее MIKO_Asterisk.
  2. Добавьте новый общий модуль «МИКО_Софтфон».
  3. Установите флажки напротив свойств «Сервер» и «Вызов сервера» для созданного модуля.
  4. Скопируйте текст, расположенный по данной ссылке, и вставьте его в модуль «МИКО_Софтфон».

Изменение типовых объектов

Откройте модуль управляемого приложения и перейдите к процедуре «ПриНачалеРаботыСистемы».

В УТ+CRM редакции 2.0.6.2 инициализация перенесена в общий модуль CRM_ОбщегоНазначенияКлиент.CRM_ИнициализироватьСофтФон()

В УТ+CRM редакции 2.0.7.1 инициализация перенесена в общий модуль CRM_ОбщегоНазначенияКлиент.CRM_ПриНачалеРаботыСистемы()

В УНФ(1.4.9.14) + 1С:CRM(2.0.8.2) инициализация перенесена в общий модуль ОбщегоНазначенияКлиентПереопределяемый.ПриНачалеРаботыСистемы(Параметры)

В 1C:CRM, редакция 2.0 (2.0.9.1) инициализация перенесена в общий модуль сфпСофтФонПроКлиент.сфпПриНачалеРаботыСистемы()

  1. Перед строкой, начинающимся с комментария «СофтФон», вставьте код
    ///
    // *** Пропущена часть иходного текста ***
    ///
     
    // PT1C / Панель телефонии Asterisk / Начало
    НазваниеПанелиТелефонии = "Панель телефонии Asterisk (МИКО)";
    МИКО_Софтфон.ВыполнитьПервичнуюУстановку(НазваниеПанелиТелефонии);
    Если МИКО_Софтфон.Использовать(НазваниеПанелиТелефонии) Тогда
    	#Если НЕ ВебКлиент Тогда
    	Отказ = Ложь;
     
    	Попытка
    		сфпФормаТелефонВнешняяПанель = ПолучитьФорму("Обработка.MIKO_Asterisk.Форма.Форма");
    		сфпФормаТелефонВнешняяПанель.ИнициализироватьПанельТелефонии(Истина, Отказ);
    	Исключение
    		Отказ = Истина;
    	КонецПопытки;
     
    	Если Отказ Тогда
    		Сообщить("Не удалось запустить """ + НазваниеПанелиТелефонии + """");
    	Иначе
    		сфпОбработаноВнешнееСобытие = Истина;
    	КонецЕсли;
    	#КонецЕсли
     
    // PT1C / Панель телефонии Asterisk / Конец
     
    ///
    // *** Пропущена часть иходного текста ***
    ///
  2. Замените условие Если в начале секции софтфона на ИначеЕсли
    ///
    // *** Пропущена часть иходного текста ***
     
    // Если Не ПользователиКлиентСервер.ЭтоСеансВнешнегоПользователя() И сфпСофтФонПроСервер.сфпИспользоватьСофтФон() // для УТ+CRM редакции 2.0.6.2
    // Если сфпСофтФонПроСервер.сфпИспользоватьСофтФон() Тогда // PT1C / Панель телефонии Asterisk
    ИначеЕсли Не ПользователиКлиентСервер.ЭтоСеансВнешнегоПользователя() И сфпСофтФонПроСервер.сфпИспользоватьСофтФон() Тогда
     
    // *** Пропущена часть иходного текста ***
    ///
  3. Перейдите к процедуре «ПриЗавершенииРаботыСистемы» и добавьте код приведенный ниже.
    Процедура ПриЗавершенииРаботыСистемы()
     
    	///
    	// *** Пропущена часть иходного текста ***
    	///
     
    	// PT1C / Панель телефонии Asterisk / Начало
    	Попытка
    		сфпФормаТелефонВнешняяПанель.ЗавершитьРаботу();
    	Исключение
    	КонецПопытки;
    	// PT1C / Панель телефонии Asterisk / Конец	
    КонецПроцедуры
  4. В начало процедуры «ОбработкаКоманды» для «Обработки» - «сфпСофтФонВнешняяПанель» - «Команды» - «ОткрытьСофтФон«добавьте код приведенный ниже.
    &НаКлиенте
    // Процедура - обработчик выполнения команды
    Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
    	// PT1C / Панель телефонии Asterisk / Начало
    	Если сфпФормаТелефонВнешняяПанель <> Неопределено Тогда
    		Если сфпФормаТелефонВнешняяПанель.Открыта() Тогда
    			сфпФормаТелефонВнешняяПанель.Активизировать(); 
    		Иначе
    			сфпФормаТелефонВнешняяПанель.Открыть();
    		КонецЕсли;
    		Возврат;
    	КонецЕсли;
    	// PT1C / Панель телефонии Asterisk / Конец
    	сфпСофтФонПроКлиент.сфпПереподключитьСофтФон();
    КонецПроцедуры // ОбработкаКоманды()

Этап 3. Настройка прав доступа

  1. Добавьте в конфигурацию новую роль «МИКО_Софтфон».
  2. Снимите все отметки о правах выставляемые по умолчанию, а для обработки MIKO_Asterisk отметьте все права.
  3. Тоже сделайте и для обработки «сфпСофтФонВнешняяПанель».
  4. Дайте право на использование компанды «ОткрытьСофтФон»
  5. Обновите конфигурацию базы данных.
  6. Запустите программу 1С под пользователем с полными правами.

Этап 4. В режиме "Предприятие"

astpanel/designer/crm2/crm2071.txt · Последние изменения: 2018/07/25 10:19 — tpor