Инструменты пользователя

Инструменты сайта


astpanel:fastintegration:bp200

Интеграция панели телефонии и журнала звонков в "Бухгалтерия предприятия, ред. 2.0"

Обратно к перечню инструкций

Инструкции составлены для конфигурации:

  • Бухгалтерия предприятия, редакция 2.0 (2.0.66.36)

Рекомендуемая версия панели телефонии: 1.2.24.12+
Рекомендуемая версия журнала звонков: 1.0.1.15+

Этап 1. Настройка правил поддержки

Перед началом выполнения работ обязательно сделайте резервное копирование конфигурации и данных!

Для начала следует разблокировать головной объект конфигурации для внесения изменений.

Порядок действий следующий:

  1. Убедитесь, что пользователи завершили работу с программой.
  2. Запустите программу в режиме «Конфигуратор».
  3. Откройте окно настройки поддержки.
  4. Включите возможность изменения конфигурации. На предупреждение программы ответьте утвердительно.
  5. В появившемся окне укажите, что объекты поставщика не редактируются.
  6. Затем для головного объекта конфигурации («БухгалтерияПредприятия») установите правило поддержки на «Объект поставщика редактируется с сохранением поддержки».
  7. Для «ФормаЭлемента» справочника «Контрагенты» установите правило поддержки на «Объект поставщика редактируется с сохранением поддержки».
  8. Для общей формы «ФормаПечати» установите правило поддержки на «Объект поставщика редактируется с сохранением поддержки».
  9. Закройте окно настройки поддержки

Теперь конфигурация готова к внесению изменений.

Этап 2. Встраивание журнала звонков

  1. Выполните действия «Конфигурация» - «Сравнить и объеденить с конфигурацией из файла»
  2. Выберите файл конфигурации «Module_Statistic_Х_Х_Х_ХХ.protect.cf»;
  3. Снимите флажок со всех объектов конфигурации
  4. Меню «Действия» - «Отметить по подсистемам файла»
  5. Выберите только те подсистемы, которые указаны на скриншоте. Выполните действие «Установить»
  6. Выполните действие «Выполнить»
  7. В появившемся окне нажимаем «Продолжить». Сохраняем отчет сравнения/объединения нашей конфигурации с файлом.
  8. Сравнение и объединение будет завершено.

Этап 3. Встраивание панели телефонии

1. Добавление обработки в подсистему МИКО_Телефония

Замените обработку МИКО_ПанельТелефонииДля1С на внешнюю, которая идет в поставке, она должна называться МИКО_ПанельТелефонииДля1С.

2. Редактирование роли

Переименуйте роль МИКО_Софтфон на МИКО_ИспользованиеСофтфона (Синоним: Использование панели телефонии Asterisk (МИКО)).

При настройке прав пользователей необходимо добавить эту роль тем, кто будет работать непосредственно с телефонией.

3. Правка модуля обычного приложения

  1. Откройте модуль обычного приложения.
  2. Определите глобальную переменную в начале модуля до раздела процедур.
    // {{doc:panel1cbp20:{ Панель телефонии Asterisk, МИКО }}} НАЧАЛО
    Перем Miko_Ajam Экспорт;// МИКО обработка управления звонками
    // {{doc:panel1cbp20:{ Панель телефонии Asterisk, МИКО }}} КОНЕЦ
  3. Перейдите к процедуре «ПриНачалеРаботыСистемы». В конец процедуры вставьте код приведенный ниже.
    	// {{doc:panel1cbp20:{ Панель телефонии Asterisk, МИКО }}} НАЧАЛО
    	// установка глобадьных переменных
    	Если РольДоступна("ПолныеПрава")
    		 ИЛИ РольДоступна("МИКО_ИспользованиеСофтфона") Тогда
    		Попытка
    			Miko_Ajam = Обработки.МИКО_ПанельТелефонииДля1С.Создать();
    			Miko_Ajam.ПодключитьСофтФон();
    		Исключение
    			Сообщить("Ошибка подключения СофтФона (МИКО):", СтатусСообщения.ОченьВажное);
    			Сообщить(ОписаниеОшибки());
    		КонецПопытки; 
    	КонецЕсли; 
    	// {{doc:panel1cbp20:{ Панель телефонии Asterisk, МИКО }}} КОНЕЦ	
  4. Создайте процедуру «ОбработкаВнешнегоСобытия».
    // {{doc:panel1cbp20:{ Панель телефонии Asterisk, МИКО }}} НАЧАЛО
    Процедура ОбработкаВнешнегоСобытия(Источник, Событие, Данные)
    	// {{doc:panel1cbp20:{ Панель телефонии Asterisk, МИКО }}} НАЧАЛО
    	Если (Источник = "MikoAjamEvent"
    		ИЛИ Источник = "MIKO_SoftPhone"
    		ИЛИ Источник = "hWindow")
    		И НЕ Miko_Ajam  = Неопределено Тогда
     
    		Miko_Ajam.ОбработкаВнешнегоСобытияАстериск(Источник, Событие, Данные);
    	КонецЕсли; 
    	// {{doc:panel1cbp20:{ Панель телефонии Asterisk, МИКО }}} КОНЕЦ
    КонецПроцедуры
  5. Перейдите к процедуре «ПередЗавершениемРаботыСистемы». В конец процедуры вставьте код приведенный ниже.
    	// {{doc:panel1cbp20:{ МИКО }}} НАЧАЛО Панель телефонии Asterisk
    	// Завершим работу Панель телефонии Asterisk перед выходом из предприятия
    	Если НЕ Отказ И НЕ Miko_Ajam  = Неопределено Тогда
    		Miko_Ajam.ОтключитьВК();
    	КонецЕсли;
    	// {{doc:panel1cbp20:{ МИКО }}} КОНЕЦ Панель телефонии Asterisk

4. Модернизация справочника "Контрагенты"

Задача: Добавить возможность произвести звонок из карточки контрагента.

Решение: Необходимо модифицировать форму элемента справочника «Контрагенты»:

Добавим в конец процедуры ПередОткрытием в модуле формы:

// {{doc:panel1cbp20:{ МИКО Панель телефонии Asterisk }}} НАЧАЛО
	Если НЕ Miko_Ajam = Неопределено 
		 И НЕ Miko_Ajam.мОбщийМодуль = Неопределено Тогда
		мОбщийМодуль = Miko_Ajam.мОбщийМодуль;
		// добавляем элементы управления на форму
 
		мОбщийМодуль.ДобавитьКнопкуЗвонкаНаПанельДействий(ЭлементыФормы.КоманднаяПанельФормы.Кнопки,
                                                          "МИКО_ВыполнитьДействие", 
                                                          "кнМИКО_НабратьНомерВыбравИзСписка");
		мОбщийМодуль.ДобавитьКнопкуЗвонкаНаПанельДействий(ЭлементыФормы.КоманднаяПанельКонтактныеЛица.Кнопки,
                                                          "МИКО_ВыполнитьДействие", 
                                                          "кнМИКО_НабратьНомерВыбравКЛ");
	КонецЕсли; 
	// {{doc:panel1cbp20:{ МИКО Панель телефонии Asterisk }}} КОНЕЦ		

Добавим новую процедуру МИКО_ВыполнитьДействие

// МИКО // Набор номера по заданному алгоритму
// 
Процедура МИКО_ВыполнитьДействие(Кнопка)
 	Действие = Кнопка.Имя;
	Если Miko_Ajam = Неопределено Тогда Возврат; КонецЕсли;
 
	Если Действие = "кнМИКО_НабратьНомерВыбравИзСписка"  ТОгда
		// Позвонить по телефону, выбранному пользователем из списка телефонов определенных у контрагента и контактного лица
		СписокОбъектов = Новый Структура();
		СписокОбъектов.Вставить("Контрагент", Ссылка);
		СписокОбъектов.Вставить("КонтактноеЛицо", ОсновноеКонтактноеЛицо);
		Если НЕ Ссылка = ГоловнойКонтрагент Тогда
			СписокОбъектов.Вставить("КонтактноеЛицо", ГоловнойКонтрагент);
		КонецЕсли; 
 
		Miko_Ajam.ПозвонитьВыбравТелефон(СписокОбъектов);
	ИначеЕсли Действие = "кнМИКО_НабратьНомерВыбравКЛ" Тогда	
		// Позовонить выбранному контактному лицу
		ТекущиеДанные = ЭлементыФормы.КонтактныеЛица.ТекущиеДанные;
		Если НЕ ТекущиеДанные = Неопределено Тогда
			СписокОбъектов = Новый Структура();
			СписокОбъектов.Вставить("КонтактноеЛицо", ТекущиеДанные.Ссылка);
			Miko_Ajam.ПозвонитьВыбравТелефон(СписокОбъектов);
		КонецЕсли;
	КонецЕсли; 
КонецПроцедуры
 

5. Модернизация общей формы печати документов

Отправка факсом текущего документа

Задача: необходимо, добавить возможность отправки сформированной печатной формы в виде факсимильного сообщения в текущий вызов.

Решение: необходимо модифицировать общую форму «ФормаПечати»:

Процедура ПриОткрытии()
	 // ... ... ... Пропущена часть исходного текста ... ... ...
 
	// {{doc:panel1cut:{ МИКО Панель телефонии Asterisk }}} НАЧАЛО
	Если НЕ Miko_Ajam = Неопределено 
		И НЕ Miko_Ajam.мОбщийМодуль = Неопределено Тогда
		мОбщийМодуль = Miko_Ajam.мОбщийМодуль;
		// добавляем элементы управления на форму
		мОбщийМодуль.ДобавитьКнопкуОтправкиФаксаНаПанельДействий(ЭлементыФормы.КоманднаяПанель1.Кнопки, 
                                                                          "МИКО_ВыполнитьДействие", 
                                                                          "кнМИКО_ОтправитьФакс");
	КонецЕсли; 
	// {{doc:panel1cut:{ МИКО Панель телефонии Asterisk }}} КОНЕЦ		
КонецПроцедуры

добавить обработчик нажатия кнопки:

// Набор номера по заданному алгоритму
//
Процедура МИКО_ВыполнитьДействие(Кнопка)
 	Действие = Кнопка.Имя;
	Если Miko_Ajam = Неопределено Тогда Возврат; КонецЕсли;
 
	Если Действие = "кнМИКО_ОтправитьФакс" Тогда
		// Обработчик нажатия на кнопку отправки табличного документа в текущий разговор
		Miko_Ajam.ОтправитьФаксомТабДок(ЭлементыФормы.ПолеДокумента);
	КонецЕсли; 
 
КонецПроцедуры

Общая печатная форма примет вид:

Этап 4. Завершение этапа встраивания

Сохранение изменений

  1. Обновите конфигурацию базы данных.
  2. В отобразившемся окне нажмите Принять

Обновление конфигурации

  1. Запустите процесс обновления конфигурации. В конфигураторе перейдите в меню «Сервис» - «Параметры», вкладка «Запуск 1С:Предприятие»
  2. В поле «Параметры запуска» укажите строку «ЗапуститьОбновлениеИнформационнойБазы»
  3. Запустите 1С:Предприятие из конфигуратора «Отладка» - «Начать отладку»
  4. Дождитесь завершения обновления
  5. Удалите из параметров запуска строку «ЗапуститьОбновлениеИнформационнойБазы». Перезапустите 1С.

Завершение настройки

Операции требовательны к ресурсам ПК. Лучше их выполнить в нерабочее время.

  1. Запустите 1С Предприятие под полными правами в пользовательском режиме
  2. «Все функции» - «Обработки» - «МИКО: Заполнить индекс телефонов»
  3. Выполните действие «Заполнить коды городов»
  4. Выполните действие «Перезаполнить индекс номеров»

На этом встраивание панели телефонии и журнала звонков в конфигурацию завершено. Теперь можно перейти к настройке продуктов в режиме 1С:Предприятие:

Обратно к перечню инструкций

astpanel/fastintegration/bp200.txt · Последние изменения: 2018/05/03 14:16 — tpor